Motorcycle Forums banner
1 - 20 of 30 Posts

·
Registered
Joined
·
4,129 Posts
Discussion Starter · #1 ·
I just got my bike back after a 3 1/2 month of seperation (not my fault) and days after I got it she will not start. I've pulled plugs and checked various this and thats. So, here's the question: With a little over 40k on the clock can the Fuel Pump (mounted in the tank) suddenly go bad? I am picking up a new fuel filter today, but it's awfully odd that I road the bike 45 miles from the paint shop, parked it for 2 days and now it won't start. The starter turns like it should and the choke (idle advance- it's fuel injected) is operating, but NO crankie. Who's got a K bike and can tell me if I'm on the right path. I am not a mechanic- I just have limited mechanical aptitude. HELP!
 

·
Super Duper Mod Man
Joined
·
10,479 Posts
I know on my E-Glide, I can hear the fuel pump wizzing before I start it, so I know it's working. Could you hear yours before and not now? Need to check 3 things. Air filter clear, gas getting to motor, and the spark plugs are sparking. All easy checks.
 

·
The Toad
Joined
·
17,458 Posts
I understand that the fuel pump/oil pump are on the same shaft and are notorious for blowing a bearing. My friend with 8 Beemers has his K100 torn down as I type this for that very problem.

Hope this helps and you get it fixed and achieve all the wonderful things you want in life. Have a nice day!
 

·
Registered
Joined
·
3,640 Posts
Well, I was going to suggest your "dunking-it-in-water" technique, Ken, but ACI probably doesn't have any water!

We're really dry here as well, but nowhere near as bad as the folks in Northern Alabama and Georgia.
 

·
Registered
Joined
·
4,129 Posts
Discussion Starter · #7 ·
Cured by doing nothing!

OK- so the bike won't start for 3 days- I decide to poke an led flex micro flashlight inside the tank and see if the wiring has come loose. No loose wires, I close the filler cap and turn on the key for shyts and giggles and low and behold the [email protected] thing starts. Why? Have no idea. But, alas, she has sprung to life. So, I will close the agency early today and celebrate with a ride around the loop. Thanks for the responses- hope everyone has a wonderful weekend. :)
 

·
Aging Cafe` Racer
Joined
·
8,715 Posts
well, I'm late to the party again, you can hear the pump run when you turn on the ignition, sounds like you have a vent hose pinched and your getting vapor lock. I'd pull the gas tank and make sure all the vent lines are not pinched.
 

·
Registered
Joined
·
7,117 Posts
Rtfm

OK- so the bike won't start for 3 days- I decide to poke an led flex micro flashlight inside the tank and see if the wiring has come loose. No loose wires, I close the filler cap and turn on the key for shyts and giggles and low and behold the [email protected] thing starts. Why? Have no idea. But, alas, she has sprung to life. So, I will close the agency early today and celebrate with a ride around the loop. Thanks for the responses- hope everyone has a wonderful weekend. :)
When I got the Concours, the guy I bought it from told me that every time it sat for more than a week, it was next to impossible to start. Sure enough, we cranked it till the battery was nearly dead to get it running the day I bought it.

When I got home, I started reading the owners manual that came with the bike. Turns out the pet**** had FOUR positions rather than the usual three. OFF, ON, RESV, and PRIME. Said right there in black and white: if the bike sits for a while, turn the petpenis to PRIME to start. Got to try it waiting for the rebuilt alternator. Started instantly after sitting 6 weeks.
 

·
Registered
Joined
·
1 Posts
I understand that the fuel pump/oil pump are on the same shaft and are notorious for blowing a bearing. My friend with 8 Beemers has his K100 torn down as I type this for that very problem.

Hope this helps and you get it fixed and achieve all the wonderful things you want in life. Have a nice day!
Say what? The electric fuel pump is in the gas tank. Just what kind of a shaft would run from inside the tank to the oil pump ???

After nearly 200,000 miles of K bike experience my guess is that he simply needs new spark plugs.
 

·
The Toad
Joined
·
17,458 Posts
Say what? The electric fuel pump is in the gas tank. Just what kind of a shaft would run from inside the tank to the oil pump ???

After nearly 200,000 miles of K bike experience my guess is that he simply needs new spark plugs.
Oops. You are right. It's the oil pump and alternator on the shaft. Never mind.
 

·
Registered
Joined
·
10,903 Posts
OK- so the bike won't start for 3 days- I decide to poke an led flex micro flashlight inside the tank and see if the wiring has come loose. No loose wires, I close the filler cap and turn on the key for shyts and giggles and low and behold the [email protected] thing starts. Why? Have no idea. But, alas, she has sprung to life. So, I will close the agency early today and celebrate with a ride around the loop. Thanks for the responses- hope everyone has a wonderful weekend. :)
Remember it's dangerous to use a flashlight. Always peer into the tank using a match.

Lifting the fuel cap cured your vapor lock.
 

·
The Toad
Joined
·
17,458 Posts
Whenever giving advice..

Remember it's dangerous to use a flashlight. Always peer into the tank using a match.

Lifting the fuel cap cured your vapor lock.
... to BMW owners it is also wise to remind them to inspect the rear drive hub frequently.
 

·
The Toad
Joined
·
17,458 Posts
Yeah, I admit it.

You just LOVE that BMW drive hub thing, don't you? I miss my Concours shaft. I'd love to see somebody make a line of drive pulleys and belts for DLs like the Uly has.
I get a big kick out of all the people who pay premium prices for the pure myth of German superiority.

Someone makes belt kits for Triumphs. Why not V-Stroms? Start a letter writing campaign to one of the belt accessory companies by V-Strom owners.
 

·
Registered
Joined
·
7,117 Posts
"Ok." (chirp chirp...chirp chirp) "Good Tip."

There is a reoccuring post on the SV 650 forum with someone developing a belt drive for the SV. How far off could that be for the 'Strom?
Hmm,that's good news. I'll have to search the topic on the forums. As far as I know, the bikes are identical except for the obvious displacement difference and then some "features" like the hydraulic clutch. Frame, swingarm, etc. are the same. The pulley size from the Wee to the Vee would undoubtably have to be different, given the variance in gearing, HP, and torque.

Thanks for the tip!
 

·
Aging Cafe` Racer
Joined
·
8,715 Posts
whats wrong with chains? you can get those gold ones with anodized black sprockets and they look cool as can be specially on a blue Suzook with black wheels and an alloy swingarm. it's the asthetics you see, it has to look cool as well as actually work
 
1 - 20 of 30 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top