Motorcycle Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2007 Roadstar Silverado. Even when its warm I have to use the choke to start it, and it kinda runs rough for a while. I had the carbs cleaned but it has never improved. Any ideas? Should I replace the jets and soak the carb even though the manufacturer claimed they cleaned it?

Also the engine has a bit of a "tinny" sound to it. It doesnt sound like the exhaust or a rattle, but more like an old truck that something is wrong with. Could that sound be carb related also? Its not the carb whine you can hear when its running, I do know that sound.

Ive only had it for a year and a half, and it always starts and never quits. I admit I dont know enough about bikes, so I want someones opinion on whether this needs attention or is pretty common.
Thx,
 

·
Registered
Joined
·
2,447 Posts
That's not a lot to go on for a remote diagnostic. There's probably a forum for the Roadstars where you can get an answer from people who have the same bike.

About the sound: did anybody screw with the exhaust system, as in "upgrade" it, or take out the baffles? Have the valves been adjusted and other basic maintenance been done?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
The shop I took it to said it shouldn't be valve related our anything like that since it only has about 3500 miles. They thought it was carb, but then they thought they fixed the carb and it still has issues. I can't ever start it without the choke, which seems odd to me because my old bike started fine unless it was below zero without the choke.
The exhaust note sounds normal (for stock) the "tinny" sound sounds more like its from the engine. I want to upgrade the exhaust and get it jetted, hope that would fix the carb issues.
I'm still checking the forums, just wondering if anyone knows. Maybe the bike us just cold blooded.
 

·
Super Moderator
Joined
·
913 Posts
I want to upgrade the exhaust and get it jetted, hope that would fix the carb issues.

I'm still checking the forums, just wondering if anyone knows. Maybe the bike us just cold blooded.
Changing the exhaust is not necessarily an "upgrade" AND you should not be making ANY mods unless and until you solve your present problem.......or decide that it's "normal" for that model.

What about the air filter? Stock or something like a K&N ??
If it's not stock, you might be AMAZED at how much better it runs if you put a stock one back on it......like not needing any choke when hot.

A double dose of Berrymans B12 Chemtool wouldn't hurt and might get something that the manual cleaning missed. Also "tweeking" the idle mixture adjustment screws out a turn or so might help a lot.

If the valves are adjustable and you don't KNOW if they were ever checked, NOW would be a good time to do that. Ditto for the plugs.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top