Motorcycle Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I'm a 68 (69 this month) years old rider. When I retired in 2003 I sold my 1975, 750K Honda, after owning it for almost 28 years. I had other cycles before and during the 750 years, but enjoyed it the most. Just recently, I was bitten once again by the riding bug and purchased a used 2000 (MM Limited Edition) Yamaha RoadStar, #0294 of 1500 manufactured. I found a 2006 transmission recall notice online and had that done. During the recall repair, the mechanic found a carburetor leak and a cracked intake manifold. These were repaired during the transmission teardown. Now for my question to any other owners of similiar cycles: During fullbore acceleration in the lower gears, when I reach certain RPMs or MPHs, the engine loses power, and starts backfiring and sputtering. If I shift into the next higher gear the problem goes away until I reach the next RPM/MPH "GOVERNOR" point. I have no problem with normal acceleration takeoffs, highway cruizing, etc. The recall mechanic advised that the large 1602cc Yamaha had "rev limiters" factory installed. Do other owners' experience this situation?:confused: This cycle does have an aftermarket air intake/filter holder installed. I am also interested in other owners/riders opinion of this particular series of Yamaha motorcycles. Does anyone know how many of the 1000 in USA of 1500 manufactured are still on the road?
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top